Page 1 of 1

435 Aux Engine Issue

Posted: Sun Mar 30, 2008 7:49 am
by bejausa
Unit is a 2002 SRE 435. Had it serviced last week. Ran in the shop and everything checked out fine. Started route that same night and aux. engine turned over but would not fire. Have worked on it for several days now - still nothing.

We've checked fuses, tattletale, wiring, fuel supply. We've even changed filters again. We're wondering about glow plugs, but it seems odd that it won't fire after having worked in the shop less than 6 hours earlier.

I am hoping this may be a simple fix that we've overlooked. Any ideas are greatly appreciated!

BEJA Environmental, Inc.

Posted: Tue Apr 01, 2008 11:49 am
by Karl Stauty
# 1 thing I would consider is lack of fuel supply! You stated that it was just serviced, check and see if fuel is getting to injectors. You may have a air lock if the fuel filter was not changed properly, as in bleeding the air out of system prior to restarting unit. Also check the fuel shut down solenoid to assure its working.


Posted: Tue Apr 01, 2008 6:47 pm
by bejausa
Thank you Karl. We'll check into that.

Posted: Fri Oct 03, 2008 7:18 am
by EliteSweepingCo
have had this same problem several times. If it is what I think it is, You need to check the small aux. fuel pump that mounts to the frame rail on the passenger side. It's just a small low pressure pump to help get the pump from the tank to the engine. You can buy a new one at any auto parts store for about $15.00. Replace it, turn your key to the on position (and make sure you can hear it pumping), let it pump for about 15 seconds, and it should start up. These pumps are not really made to run all the time, so I have wired a switch on mine so I can just turn it on to get the fuel back to the engine after a filter change. Once the fuel is to the engine you don't need the pump because you then are feeding it from vacuum.